MadTracker.org
Forum - ASIO mode with Creative X-fi
Register Register Log in Log in Profile Profile Search Memberlist Usergroups FAQ FAQ
 Forum
Bug report
 ASIO mode with Creative X-fi
Reply to topic Post new topic  
MagnarTBL
Registered User


Joined: 18 Jan 2005
Location: Ronneby, Sweden
PostPosted: Mon Jan 08 2007 15:09    
ASIO mode with Creative X-fi
Reply with quote

Hi,
Using Creative SB X-Fi card and ASIO mode cause Madtracker process not to end properly when you close MT2.6.1.

I've had this problem for half a year now, any update on this issue?

BR Magnar
 Back to top
View user's journal Send private message Visit poster's website MSN Messenger
MagnarTBL
Registered User


Joined: 18 Jan 2005
Location: Ronneby, Sweden
PostPosted: Sun Jan 21 2007 12:56    
Reply with quote

Another problem with madtracker is that if you just start the program and let it play a simple module (no vst or such, just samples) for a day or two, it will eventually just hang. Seems to be some wierd memory leaks or problems with the interface talking to the audio drivers.

/M
 Back to top
View user's journal Send private message Visit poster's website MSN Messenger
Ravana
Registered User


Joined: 18 Nov 2005
Location: Oulu, Finland
PostPosted: Sun Jan 21 2007 14:33    
Reply with quote

MagnarTBL wrote:
Another problem with madtracker is that if you just start the program and let it play a simple module (no vst or such, just samples) for a day or two, it will eventually just hang.


Wow, can I ask what drove you into testing that one?


http://www.mikseri.net/artists/thejollynekromanseri.51046.php

http://www.mikseri.net/artists/bewaretheconstruct.62202.php

MT source files available if requested (maybe)
 Back to top
View user's journal Send private message Send e-mail
Psalm 97
Registered User


Joined: 24 Dec 2006
PostPosted: Sun Jan 21 2007 20:29    
Reply with quote

yes, I would also like to know why you were running a song for more than a day. Forgot and left it on with the speakers off?


Only what is done for Christ will last.
 Back to top
View user's journal Send private message
MagnarTBL
Registered User


Joined: 18 Jan 2005
Location: Ronneby, Sweden
PostPosted: Sun Jan 21 2007 20:33    
Reply with quote

Not really a test, but I usually leaves my computer on all the time. Saves me the time to boot it up. Smile

Had just started a very simple module structure, a couple of ordinary 44Khz 16bit samples in it, left it playing the song on the speakers in play mode, went away for work business a couple of days, got home and the pc was stuck with a terrible noise sound in the speakers - and madtracker frozen... Had to terminate the application from task manager to get it all right again.

Actually, this is something that has happen quite many times in the past too, just never gotten to write about it as a bug before now.

And, for those wondering - i got my pc's in a own music studio - not in my house. And the speakers wasn't really set to max loudness either. Smile

BR Magnar
 Back to top
View user's journal Send private message Visit poster's website MSN Messenger
Frazze
Registered User


Joined: 12 Apr 2004
Location: Lund, Sweden
PostPosted: Sun Jan 21 2007 21:16    
Reply with quote

Hehe, nice.


http://www.last.fm/music/8ism
 Back to top
View user's journal Send private message Send e-mail Visit poster's website
Psalm 97
Registered User


Joined: 24 Dec 2006
PostPosted: Mon Jan 22 2007 02:56    
Reply with quote

To the original question: As long as it exports all right, I'd think it wouldn't matter much how you have to shut it down.

It does export alright, yes?


Only what is done for Christ will last.
 Back to top
View user's journal Send private message
MagnarTBL
Registered User


Joined: 18 Jan 2005
Location: Ronneby, Sweden
PostPosted: Mon Jan 22 2007 09:15    
Reply with quote

Successful WaveExport depends on if I use ASIO or the directx mode for the audio driver.

Currently I use DirectX mode, since that stops the application from "hanging" and not exit correctly when I want to quit the Madtracker applicatino.

If I use ASIO mode, I cannot export to Wave - and the MadTracker just screws up when I try to quit the application whereas you need to terminate the application from Task Manager, and chose between sending or not sending a bug report to Microsoft about the Memory violence happened.

BR Magnar
 Back to top
View user's journal Send private message Visit poster's website MSN Messenger
Franklin van Uden
Registered User


Joined: 26 Apr 2005
Location: The Netherlands
PostPosted: Mon Jan 22 2007 23:59    
Reply with quote

Did u check the latest asio drivers for the soundcard ?
Did the trick for me a while back, well for my soundcard which is creative as well Smile


Music ... is endless ... Work in progress ...

 Back to top
View user's journal Send private message Visit poster's website MSN Messenger
MagnarTBL
Registered User


Joined: 18 Jan 2005
Location: Ronneby, Sweden
PostPosted: Tue Jan 23 2007 05:03    
Reply with quote

Tried the newest Creative drivers from the "product update", still doesn't work...

/M
 Back to top
View user's journal Send private message Visit poster's website MSN Messenger
Franklin van Uden
Registered User


Joined: 26 Apr 2005
Location: The Netherlands
PostPosted: Wed Jan 24 2007 19:22    
Reply with quote

try to set the pci latency buffer in the bios on 64 instead of the (most cases) default 32, should be improving the stability (also a common SB problem)


Music ... is endless ... Work in progress ...

 Back to top
View user's journal Send private message Visit poster's website MSN Messenger
Reply to topic Post new topic  
Display posts from previous:   
Page 1 of 1 All times are GMT + 1 Hour


Powered by phpBB © phpBB Group

Copyright © 1998-2005 Yannick Delwiche
All rights reserved